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APP: Health Check Failed on WebServiceHelper.dll Version

Symptom

Anveo's Health Check fails on WebServiceHelper.dll Test showing an error message like:

WebServiceHelper.dll Version... Failed: Required version of WebServiceHelper.dll is ... Detected version is ...

 

Causes

  1. WebServiceHelper.dll is not installed yet.

  2. All Anveo Client Suite components must fit together. In this case, Objects in Microsoft Dynamics NAV and WebServiceHelper.dll is not a valid pair.

  3. The WebServiceHelper.dll is blocked by Windows.

 

Solution

Copy the correct version of WebServiceHelper.dll in your Add-ins folder of your Microsoft Dynamics NAV installation. Restart Microsoft Dynamics NAV web services afterwards and re-run your test.

3. only: Make sure, the dll-file is not blocked by Windows. Open file properties and press "UNBLOCK", if visible.

 

Note: This article is for Anveo Client Suite 6 and newer.

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