WEB: Web Portal login fails with "Unauthorized"


After you tried to login into Anveo Web Portal, you'll get the following error-message:

The request failed with HTTP status 401: Unauthorized.



The login into the Dynamics NAV Service Tier (= Dynamics NAV Web Services) failed by Anveo.
(This message does not appear if a wrong license key exists.)

Solution 1

  • Open WebServices.config.xml in IIS folder in C:\inetpub\wwwroot\AnveoWebStore.
  • Set DomainName, NAVUserName and NAVUserPassword to an existing NAV User with the proper NAV Security permissions.
     <Security useNTLM="false">
      <!--Required for all users without a defined Security Group -->
      <default domain="DomainName" username="NAVUserName" password="NAVUserPassword"/>


  • NAV 2009 only: If required, synchronize NAV rights again and restart NAV Server and NAV Web Services by stopping both services first, then start both services again.
  • Restart IIS Application Pool AnveoWebStore

Solution 2

First make sure, username and password are set correctly (see Solution 1).
If the SQL-Server and the NST (NAV Service Tier = NAV Web Services) are installed on different computers, make sure, that Delegation is set up correctly.
This configuration is quite time-consuming and not done by just "setting up some checkboxes".

Walkthrough: Installing the Three Tiers on Three Computers:

and How to: Configure Web Services with Delegation:

NAV 2009 only: We highly recommend not to use a delegation scenario. Please install Dynamics NAV web service on your SQL server.


Solution 3

On some servers we have seen that the encoded Web Service URL is having problems.

This variant is ok (%20 for a space)



This variant sometimes causes issues %20 for a ,


Working alternative:


Anveo Client Suite 6.01

Beginning with Anveo Client Suite 6.01, you can also set UseNAVWSAddressUrlEncoding to false instead.


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request