Follow

APP: Anveo Server does not start up showing "Error 15010: Configuration error."

Symptom

On start-up of Anveo Server, an error message occurs saying Error 15010: Configuration error."

 

Causes

This behavior may be caused by different configuration problems. Please see multiple possible causes and solutions below.
You will find the cause in Anveo Server Log file that is automatically created in subfolder Transfer\ANVEOServiceTierLog. If no log is available in log folder, please open Windows Event viewer for further information.

Cause 1 - Missing Rights

Service does not have a user with local administrator rights. In Windows Event log, you will find the following error message:
Service cannot be started. System.Exception: HTTP could not register URL http...

Solution 1

Give user for Anveo service Windows administrator rights for local machine.

 

Cause 2 - Certificat Not Found

Error message: SSL Config Processing Exception:could not find your certificate
If you have selected to use your own certificate, the Anveo Server cannot find your certificate.

 

Solution 2

  • Check your thumbprint in your configuration file:
    <CustomerCertificate enabled="true" certificateThumbprint="DE21EE84F7626C7BCB83B08741B125DF6211A346" />
    The thumbprint must be excatly the same as shown in your certificate.






    Add Certificate Snap-In:




    Open your certificate:




    Compare your Thumbprint here with your setting in Anveo Server configuration file.



    Note: If you have used copy&paste to transfer the value, make sure there is no hidden character at the beginning or at the end of the thumbprint.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments